PCB Repair Logs Pacland

From Aussie Arcade Wiki
Jump to: navigation, search

Pacland

Pacland
Marquee pacland.jpg
Manufacturer Bally Midway
Year 1984
PCB Image Reserved
Pin Out Pacland

Repairer: VectorGlow
Forum Thread: Pacland PCB Repair

Symptom: Assorted colours wrong
Cure: Two faulty chips – the LS298 at location 1P had pin 12 stuck high, and the MB7132 PROM at location 4N was faulty

Symptom: Error 3 0 0 on boot up
Diagnosis: Error indicates that the 6116 RAM at location 9P is faulty (and running a RAM test on the sprite RAM (2000 to 37FF) on my Fluke 9010A gave an error at address 2800 BTS 08). Replaced that RAM but the fault remained. So replaced the LS245 at location 8P that the aforementioned RAM’s data lines connect to and that fixed the fault
Cure: Replaced faulty LS245 at location 8P

Symptom: Board booting and is playable but a lot of moving garbage obscuring and corrupting most of the background and some of the sprites
Diagnosis: Piggy-backed the 6116 RAMS and the LS245’s besides them and found that the LS245 at location 8S was faulty
Cure: Replaced faulty LS245 at location 8S

Symptom: Board booting but giving a 5 0 0 error indicating a faulty 6116 RAM at location 9S and the game displayed some garbage on the background
Diagnosis: Decided to double check the error using my Fluke 9010A – on testing the Video RAM in address range 0 to FFF I was getting a decode error for bit 3 and as the RAM warmed up the errors became more numerous in all areas associated with the RAM at location 9S – piggy-backing a good 6116 on top of the suspect one made the Fluke errors disappear. Removed the suspect RAM and put it into my Wellon VP-280 programmer to test it – the VP-280 indicated that there was a problem with pin 6 of the RAM
Cure: Replaced faulty 6116 RAM at location 9S

Symptom: Board tries to boot but just displays 5 0 5 0 and constantly resets
Cure: Bad outputs on the LS373 at location 2D - replaced

Symptom: Some background graphics were corrupted
Diagnosis: pin 2 of the 2764 EPROM (PL4 13) at location 6T wasn’t giving a reading with the logic probe, and on tracing this back it was found that it came from pin 5 of the LS174 at 7P. This is an output pin – all inputs were good.
Cure: Replaced the LS174 at 7P

Symptom: Dotted lines vertically down far left side of display and within some sprites
Cure: Replaced faulty 2148 RAM chip at location 3S

Symptom: error 1 0 0 on power up
Cure: Faulty 6116/2016/M58725 RAM at location 9M – replaced

Symptom: 2 0 0 appearing on power up then hanging
Cure: Bad LS32 at location 5B – replaced

Symptom: All sprites moving vertically upwards
Cure: Re-seated Custom 12xx at location 7H


Boot up error codes:

x1 x2 x3

x1 = RAM related
x2 = ROM related
x3 = RAM at 4E ? EG if RAM at 4E is removed or faulty on boot up the error code will be 0 0 1


Examples:

2 0 0 = LS32 at 5B (but would usually be the RAM at 9N)
9 0 0 = customs 2B or 3F removed


RAM Errors:

On boot up, if one of the main cluster of seven 6116 RAMs is faulty you will get an error indicating which RAM is at fault; counting top to bottom (with the board component side up, edge connector to the right), see info below.

So RAM 1 is at location 9M, 2 at 9N, etc. The error code is followed by ‘x’ where ‘x’ is a number from 1 to 7, RAMs arranged as follows (as mentioned, with the board component side up, edge connector to the right):

1
2
3
6 4
7 5

An error code of 0 0 1 indicates that the 6116 RAM at location 4E is faulty


Customs:

12xx at 7H – sprites, if faulty sprites may scroll upwards
11xx at 6H – sprites, if faulty sprites are black blocks
13xx at 9L – background scrolling, if faulty background details, etc
04xx at 10M – if absent gives error 2 0 0 then 2 0 1


Some EPROMs and PROMs:

PL4-13 removed – lots of vertical white lines
PL1-5 removed – most text missing
PL2-12 removed – most graphics missing
PL1-4 removed – some background graphics missing
PL1-3 removed – no sprites



Back to PCB Repair Index